■ 外字作成とバックアップについて ■

for Win95/98/XP
VISTAの場合も、外字エディタは同じですから参考にして下さい。
VISTA使用者はまずこちらをご覧下さい。(VISTA上で「外字が正しく表示されない」場合の対処方法

[戻る]


※文中の図については、以下をクリックし参照して下さい。
■図1〜2(文字コード表関係)
■図3〜8、13〜15(外字エディタ関係
■図9〜12(IME関係 


外字作成の実際

外字を作成するためには、作成しようとする外字の形に近い既存の文字を探すことから始めます。
何もないところから外字を作成するのは大変です。文字の形はもちろん、バランスや、既存文字と大きさを合わせる事も大切です。
それに対し、既存の漢字から似ている部分を切り抜いて、くっつけあい作成(合成)したほうが簡単で綺麗にできあがります。

ここでは例として鐘の”ケイ”を作成してみます(打ケイ三声のケイです)。お寺さんの差定には不可欠な文字です。

◆”ケイ”を作るための部品を探す
既存の漢字を探してみると「鏨」の金の部分と、「磬」の上の部分を組み合わせると簡単に合成出来そうです。今回はこの2字を使用します。

◆部品となる漢字の文字コードを得る
文字コードは、あとで使用する外字エディタ内で使用します。文字コードを調べておかないと、膨大な漢字表から目的の漢字をひとつひとつ探さないとならなくなります。

文字コードを得るためには、カナ漢字変換プログラム(MS-IMEやATOK)に入っているツールやWINDOWSに入っている文字コード表、文字コードの載っているOA辞典などを使用します。
ここでは、WINDOWSに入っている文字コード表を使用します。

スタートボタン → プログラム → アクセサリ ( → システムツールにある場合もある) メニューから文字コード表を選択します。
(もし、他を探しても無い場合は、インストールされていません。インストールするか他のツールを使用して下さい。)

文字コード表が起動したら、フォント名を「MS 明朝」にします。(無難なので)
(文字コード表の画像 <図1>参照)
「読み」「部首」ボタンを使用して目的の漢字にたどり着きます。目的の漢字をクリックすると、文字コード欄に文字コードが表示されます。

「鏨」を調べると文字コード欄に[ 0xe853]と表示されます。最初の2字”0x”はこの値が16進数の数値であることを表しています。ですから、純粋な文字コード値は”e853”であることがわかります。
(文字コード表の画像 <図2>参照)
同様に「磬」を調べて下さい。文字コードは”e1fc”ですね。

ちなみに16進数は数字の0から9とアルファベットのAからFまでを使用します。見た目には”ゼロ”とアルファベットの”オー”は区別が付きにくいので注意して下さい。16進数では”オー”は使用しませんから
0はすべて数字の”ゼロ”です。

もう一つの注意点です。
今回の文字コード表では関係ありませんが、他のツールを使用して文字コードを得る場合、必ずSHIFT-JIS(シフトJIS)の文字コードを得ることです。文字コードには、JIS、シフトJIS、句点、などの種類があります。上記文字コード表では、シフトJISしか表示しませんから問題ありませんが、他のツールでは必ず文字コードの種類を選択できますから、間違えないようにして下さい。

標準の外字を作成する

スタートボタン → プログラム → アクセサリ のメニューから外字エディタを選択します。
(もし、他を探しても無い場合は、インストールされていません。インストールして下さい)

外字エディタ起動
Windows 98〜,XP の場合は、「コードの選択」ウィンドウが開いた状態で起動します。
(開かない場合は、メニューバー(画面上)の編集(E)メニューからコードの選択を選ぶ)

win95の場合は、メニューバー(画面上)のファイル(F) → フォントの選択 を選び、外字フォントの種類内の「標準の外字」にチェックを入れ、OKボタンを押します。もう一度メニューバーのファイル(F) → コードの選択 を選んで下さい。

コードの選択
コードの選択ウィンドウから、外字を作成するコードを選択します。
今回はF040に作成します。画面左上のF040に該当する□枠をクリックします。
コード欄に[ F040 ]、ファイル名欄に[ EUDC ]とあることを確認して下さい。OKボタンを押すと編集ウィンドウが開きます。
この編集ウィンドウに書き込んだ図形が、文字コードF040に当てはめられ、使用されることになります。

参照ウィンドウ
先に文字コードを調べた、参照用の漢字を参照ウィンドウに表示させます。
メニューバーのウィンドウ(W) → 参照 を選択すると、参照する漢字を選択するウィンドウが開きます。<図3>
次に、フォント(F)ボタンを押し、フォント選択ウィンドウを開きます。フォントリストボックスで「MS 明朝」を選択し、OKボタンを押すと、<図3>のウィンドウに戻ります。

<<ここで、フォントをツルータイプフォントにすることは大変重要です。標準の外字を作成する場合、MS明朝か、MSP明朝を選択して下さい。各書体にリンクした外字を作成する場合は、目的の書体を選択することになります。>>
<<日本語フォント名には、最初に@がついているフォントと、ついていないフォントの2種類が用意されています(例:MS明朝と@MS明朝)。@がついているフォントは縦書き用フォントです。このフォントを選ばないで下さい。ちなみにこのフォントを選択すると、参照ウィンドウには、90度横に回転した文字が表示されてしまいます。>>

<図3>のウィンドウで「鏨」を選択
「鏨」のコードを入力します。コード(C)入力域をクリックすると入力可能になります。E853と入力すると<図3>の状態になります。
(コードを調べていないと、漢字が表示されているボックス内の垂直スクロールバーを操作して「鏨」を見つける事になります。)
フォントが「MS 明朝」になっていることを確認したら、OKボタンを押し、外字エディタに戻ります。

参照ウィンドウから部品をコピー(鏨)
外字エディタの状態は<図4>のようになっています。
編集ウィンドウと参照ウィンドウとに分かれて表示されています。

それでは、参照ウィンドウにある「鏨」から”金”の部分だけコピーします。
外字エディタの左端にあるツールボックス(ペン、ブラシ、斜線、、、のアイコンが縦に並んでいる)で□のボタンを押します。(下から3つめのアイコン)
そして、参照ウィンドウの”金”の部分をドラッグして囲みます。この時、囲む領域は一番左端から下へ大きく囲みます。”金”の周りだけを囲むと、編集ウィンドウへコピー後、位置合わせに苦労します。”金”以外の部分が入っても気にしないで下さい。あとで消しゴムで消すことが出来ます。

<<領域を大きく取ることは重要なポイントです。各書体は、それぞれ、文字の大きさや文字位置が違います。例えば明朝書体は、サイズいっぱいを使って文字を作りますが、毛筆体は細長くて小ぶりで、同じフォントサイズでも明朝より1まわり小さく見えます。
でたらめに作ると、文章を印刷した時など、外字だけ不揃いで大変目立ちます。
領域を大きく取ると、左や下側に揃えやすく文字のレイアウトも揃います。>>

囲んだら、メニューバーの編集(E) → コピー を選択し、もう一度メニューバーの編集(E) → 貼付け を選択すると、囲んだ部分が編集ウィンドウへコピーされます。
画面左上を起点にコピー図形が表示されますから、下へドラッグして移動します。(注意:コピー図形の枠内以外をクリックしてしまうと、ドラッグして移動出来なくなります。その時は、編集 → 元に戻すを選択してやり直して下さい。)
<図5>のようになりましたか?

(ここで、”金”の周りのゴミを消しても良いのですが、今回は後回し。出来る方は処理して下さい。)

参照ウィンドウから部品をコピー(磬)
同様に「磬」から、上の部分をコピーします。
メニューバーのウィンドウ(W) → 参照 を選択し、コード[ E1FC ]を入力。フォントは先にMS明朝を指定したので今回は指定する必要はありません。が、一応、MS明朝と表示されているのを確認、形も「磬」が表示されたのを確認してからOKボタンを押します。

ツールボックスで□のボタンを押します(今回は既に押している)。参照ウィンドウの「磬」から、上の部分をドラッグして囲みます
メニューバーの編集(E) → コピー を選択し、もう一度メニューバーの編集(E) → 貼付け を選択すると、囲んだ部分が編集ウィンドウへコピーされます。位置がずれていたらドラッグして調整します。
<図6>のようになりましたか?

文字の整形
文字図形をツールボックスの消しゴムツール(一番下のアイコン)や、ペンツール(一番上)を使って整形します。

<図7>は、消しゴムツール、ペンツールを使用して、声の部分を整形しているところです。
整形中に間違えたら、メニューバーの編集 → 元に戻す で、一回分だけ元に戻すことが出来ます。
全体を整形すると<図8>のようになります。

外字登録
完成したら登録します。
メニューバーの編集 → 同じコードで保存 を選択すると登録されます。

続けて別の外字を作成する場合、編集 → コードの選択 を選んで最初から行います。(win95の場合は、ファイル(F) → コードの選択)


外字をIMEに単語登録する

外字を作成しただけでは、不十分です。カナ漢字変換プログラム(IME)に単語登録しなければ大変不便です。
以下、MS−IME(WINDOWS標準添付)とATOK(一太郎に添付)について単語登録の方法について記します。ご自分の使用されているIMEの記入部分を参照して下さい。

◆外字をATOKに単語登録する
ワープロ(一太郎など)を立ち上げます。
IMEがONの状態になっていることを確認します。<図9>
<図9>の「R漢」ボタンを押す。(または「カナ漢」ボタン)
メニューが表示されるので、「コード入力」を選択する。<図10>のコード入力ウィンドウが表示されるので(何もクリックせずに)、[ F040 ]と外字コードを入力します。先に作成した”ケイ”が表示されるのでEnterキーを押して確定し、ワープロ上に表示させます。

そのワープロ上の”ケイ”1字をドラッグして反転表示させます。メニューバーの編集 → コピーを選択します。キーボードでCtrlキーを押しっぱなしにしてF・7キーをポンと押すと、単語登録ウィンドウが表示されます。<図11>
(単語登録ウィンドウが表示できない方は、<図9>の右から2番目のアイコンをクリックしてメニューを表示させ、単語登録を選択します。)

うまく出来れば、<図11>のように単語の欄に外字の”ケイ”が表示されるはずです。表示されない場合は、1文字コピーする所からやり直します。

あとは読みに”けい”と入力し、OKボタンを押すと登録されます。
ついでに、ワープロ上で「打”ケイ”」などの熟語を入力し、同様の操作で登録して下さい。

◆外字をMS−IMEに単語登録する
ワープロ(WORDなど)を立ち上げます。
IMEがONの状態になっていることを確認します。<図12>
漢字入力モードで[ F040 ]と入力し、(Enterキーで確定するかわりに)F5キーを押すと、外字ウィンドウが表示されます。

目的の外字をクリックすると、ワープロ上に未確定の状態で表示されます。Enterキーで確定します。
そのワープロ上の”ケイ”1字をドラッグして反転表示させます。<図12>の左から4番目のアイコンをクリックすると単語登録ウィンドウが表示されます。

すでに単語の欄に外字の”ケイ”が表示されているはずです。表示されない場合は、1文字ドラッグする所からやり直します。

あとは読みに”けい”と入力し、OKボタンを押すと登録されます。
ついでに、ワープロ上で「打”ケイ”」などの熟語を入力し、同様の操作で登録して下さい。


書体ごとに外字を作成する

標準の外字を作成しておけば、とりあえず他の書体でも印刷されます。
しかし、毛筆書体の印刷中でも標準の外字を使用すると、外字だけは明朝で印刷されます。
標準の外字を作成する時、参照した書体がMS明朝だから当然です。

毛筆印刷の時は外字も毛筆で印刷したい場合、毛筆用に外字を作成する必要があります。
では、外字エディターを起動します。
起動すると、「コードの選択」ウィンドウが開きます。これは、標準の外字用なので今回はキャンセルをクリックし、パスします。

◆「フォントのリンク」で外字ファイルを選択する

<Windows 98/XP の場合>
メニューバーのファイル → フォントのリンクを選択します。
(フォントを大量にインストールしている場合、ここで長時間待たされます。マウスポインタが砂時計にならずにそのままなのでハングしたかと思ってしまいますが、短気を起こさず待ち続けます。笑)

フォントのリンクウィンドウが開きます。<図13>
外字フォントの種類内の「指定したフォントにリンクする」にチェックを入れる。
フォントの選択リストボックスが選択可能になりますから、ここで目的のフォントを探します。(ここではHG正楷書体を探す)

>>初回のみの場合
書体名の右横に「未選択」とあるはずです(既に作成済みの場合は、保存ファイル名が表示される)。
「名前を付けて保存」ボタンを押します。<図14>の外字ファイル名の変更ウィンドウが開きます。
保存する場所は[ WINDOWS ]そのままで、ファイル名に外字ファイル名を入力します(例:[外字HG正楷書])。
保存ボタンを押して外字エディタに戻ります。(<図15>のようになります。)
>>2回め以降の場合
目的のフォントを探したら、クリックして選択します。
書体名の右横に保存ファイル名が表示(ここではHG正楷書体を選択)されているのを確認し、『OK』ボタンをクリックします。

このあとは、今までの外字作成と同じです。
メニューバーの編集(E)メニューからコードの選択を選び、開始して下さい。
(編集画面の上側に表示されるファイル名が選択したファイル名になっていることを確認して下さい。ここでは、[外字HG正楷書])

<win95の場合>
メニューバーのファイル(F) → フォントの選択 を選び、フォントのリンクウィンドウが開くまで待ちます。外字フォントの種類内の「書体を意識した外字」にチェックを入れます。
関連付けるフォントリストボックスで目的のフォントをクリックします。(ここではHG正楷書体を選択)

書体名の右横に「未選択」とあるはずです(既に作成済みの場合は、保存ファイル名が表示される)。
「変更(M)」ボタンを押します。外字ファイル名の変更ウィンドウが開きます。
保存する場所は[ WINDOWS ]そのままで、ファイル名に外字ファイル名を入力します(例:[外字HG正楷書])。保存ボタンを押して外字エディタに戻ります。

このあとは、今までの外字作成と同じです。
メニューバーのファイル(F)メニューからコードの選択を選び、開始して下さい。

◆コードの選択 について【重要】 (Win95…Win-XP すべて共通)

標準の外字で作成したコードと同じコードに、同じ文字を作成して下さい。
ここでは、F040に”ケイ”を作成しましたから、どの書体でもF040には”ケイ”を作成します。
標準の外字で作成した文字数だけ、他の書体でも作って下さい。
(例:標準の外字で、10字作成したら、外字HG正楷書でも10字作成


作成した外字ファイルのバックアップ
せっかく作成した外字です。バックアップしておきましょう。
外字ファイルは、拡張子が「EUF」「TTE」の2ファイルで1セットです。

◆標準の外字ファイル
Windows 98系の場合、WINDOWSのインストール先にあります。(例:Cドライブにインストールした場合、C:\WINDOWS)
Windows XPの場合、WINDOWS\FONTSにあります。
ファイル名は、「EUDC.EUF」と「EUDC.TTE」の2ファイルです。

◆書体ごとに作成した外字ファイル
<図14>の外字ファイル名の変更ウィンドウで指定したファイル名がそれです。
上の例ではWINDOWSのまま[外字HG正楷書]と入力しましたから、ファイルは、C:\WINDOWSにあります。(Windows 98系の場合)
ファイル名は、この例では[外字HG正楷書.EUF][外字HG正楷書.TTE]の2ファイルです。

◆エクスプローラでFDなどへコピー
ファイル名が分かったところで、エクスプローラでFDなどへコピーして保存して下さい。
よほど沢山の外字を作成しない限り、2ファイル1セットの書体はFDへコピー出来るはずです。

エクスプローラで拡張子を表示しない設定にしている場合(初期値)、同じ名前のファイルが2つ表示されることになります。そのまま2つを選択してコピーして保存しておいて下さい。


■Windows XPの場合、エクスプローラでは外字ファイルが見えない場合があります。
たぶん、Windows 98系から取り込んだ場合、見えないと思います。
その場合、コマンドプロンプトやファイル操作ツールを使用してファイルをコピーする必要があります。
または、以下のようにして検索します。
(拡張子"euf", "tte"を検索し、それらをコピーまたは、FDなどへ送ります。)

  1. スタートボタン → 検索 を選択します。
  2. 「ファイルとフォルダすべて(L)」をクリックし、「ファイル名のすべてまたは一部(O)」に”*.euf;*.tte”と入力します。(””内を入力)
  3. 「探す場所」は、ハードドライブです。
  4. 検索ボタンを押すと、拡張子が「EUF」「TTE」の外字ファイルが検索されます。
    (うまくできない場合は、”*.euf;*.tte”の入力に間違いがあるか、探す場所が違っています。)
  5. あとは、これらのファイルを選択し、フロッピーディスクにコピーします。
    (検索されたファイルを全て選択し、右クリックし、「送る」 → 「3.5インチフロッピーディスク」です)

外字作成の注意点



拡張外字
MS明朝などを文字コード表で見て下さい。ずーっと下の方に下図のような文字が突然出てきます。
IBM拡張外字などと呼ばれている文字です。外字として作ろうと思っていた文字がここにないか、まず探してみて下さい。ここにあれば、作る必要はありません。
文字コードを取得し、IMEに単語登録してしまえば、通常の文字と同様に使えます。
拡張外字は、書体により含まれていない場合もあります。が、明朝、ゴシック系列には間違いなくありますし、HG正楷書体にも含まれています。


「g」などの文字が格納されている拡張外字部分。探すとけっこうありますヨ。


書体により、サポートされていない場合もあります。
ポップ書体、行書体などには含まれていない場合が多いようです。



★JIS補助漢字

上記の拡張外字に加え、WINDOWS-XPなどにはUnicode(ユニコード)に対応しているソフトでさらに5801字の補助漢字が使用できます。
使用できる書体は、WINDOWS-XPに付属の明朝体・ゴシック体です。
また、市販のダイナコムウェアの「JIS補助漢字5801」(15,750円)をインストールすることで、明朝・ゴシック・楷書・行書の11書体でも使用可能になります。
(2004/8現在、対応フォントは上記だけのようです。2008に発売中止)

JIS補助漢字内には、差定で必ず使用する”打けい”(けい=馨の香を金にした文字)の”けい”や、”鼓はつ”(はつ=金へんに友+てん)も含まれています。かなり重宝します。

VISTAになり、使える文字がかなり増えました。
ただし、付属のMS明朝、MSゴシック、メイリオだけです。
それと同等の文字数を扱える毛筆体フォントはまだ出ていないようです。

OpenType Pro (ダイナコムウェア)シリーズは、第3、第4水準まで収録されています(VistaのMS明朝などより文字数が多い)が、使用出来ませんでした。
レイアウトが崩れてしまいます。
「OpenType Pro 行書・楷書13書体 \42,000」を購入して試しましたが、ダメでした。ショック